The Pawn :: iOS (iPad, iPhone and iThings)



  • edited August 2017
    iPad: passing the dragon, you die. Turn undone; then only description of location is displayed. Typing inventory, se, tapping on items: seems no response because you die every time. It's a bit confusing. I think the player command should appear also in the description window
  • try pressing undo a few times, because sometimes you can get stuck where you die, then undo, then die etc.

  • The Dragon puzzle is something i want to change for the re-built version.

  • Theme selector messed up my colours :'(

    Think it happened after I selected a dark theme.

    Went back and forth, tried other themes, even restarted the pawn, still the same.

  • Restarting ipad also does not help.

  • Wooah! That's bad!

    Thanks for reporting this, a serious problem. I'll try and sort this out ASAP and make a new release.

    mysterious? how it could affect the picture colors...??

  • Have no idea. Initial thought was that it somehow reverted to negative, but it is not. Maybe colour palette corruption?

  • Theme selector on iPhone seems ok
  • so perhaps this is a iPad problem? it's weird. Thanks for the info. I'll investigate.

  • edited August 2017

    @hugh said:
    so perhaps this is a iPad problem? it's weird. Thanks for the info. I'll investigate.

    Can also be our personal ipad. I will try and reproduce the problem on the ipad at work, and revert. Unfortunately it will be on Monday.

    • derail -

    @robriz said:

    Muttley? Dastardly doing his best to win the races still? :smiley:

    • derail ends -
  • what kind of iPad is it? I'm trying out this build on the Amazon Device farm. So far, iPad Air is ok. I'll try the mini next...

  • iPad mini 2 seems ok. However, only tried the basic run game and change theme to dark. Perhaps there's a magic sequence of events to try...

  • Ipad air (wifi only)

  • edited August 2017

    @hugh said:
    iPad mini 2 seems ok. However, only tried the basic run game and change theme to dark. Perhaps there's a magic sequence of events to try...

    I moved around a bit as well. Think I went south, then east, faffed around a bit with Kronos, pulled up the compass rose, went west, faffed around with the new themes, pulled the map down, went back to original start location, and then only did I notice the wonky colours.

    Think I'll do a reinstall of the pawn and see what happens.

  • This event is also weird to me. I suspect that it may be our ipad, since other ithings does not exhibit this anomaly.

  • edited August 2017

    Thanks. Just fixed a silly bug i noticed, the phrase "Strand Games" is wrong in the start text, comes out as "Stra D Games". Was a glitch in the text, so ignore this if you see it.

  • Bah. Did a reinstall. From the opening sequence the colours are still buggered up.

    Will update the pawn on work ipad and let you know if it is ok or not.

  • Ok thanks. I'm going to try some more investigation here. I think there is an actual problem here, just need to smoke it out...

  • New iOS build on the streets. I made a few adjustments to the picture loading (which may or may not affect the mystery color bug). Also fixed some dark theme colors


    Added some cool, retro IBM fonts from here.

    here's the game with IBM VGA font:

  • Bleh. The Pawn opens, then closes again aftrr the update.

    Will check tomorrow at work what is going on. No doubt it is some foul magic from Kronos at work.
  • So it doesn't even run at all anymore? This is bad!

  • @hugh said:
    So it doesn't even run at all anymore? This is bad!

    Will let you know tomorrow!

  • Great new old style fonts! Still waiting for old fashion green or orange phosphorus monitor style..
  • what we need is a shader for that!

    because the old green screens weren't just green, you'd have to reproduce the way things were made by the scanlines to get that effect.

    Now, you got me thinking. i wonder if there's one already out there...

  • Lovely.

    It works lovely (on the work's ipad). Colours are all there. Dark themes work.

    Everything is hunky-dory. The guru seems most pleased with the dark theme. And the CGA font makes it all retro :smile:

    Somebody mentioned green screens and the such - it won't be used all the time, but just for kicks, to see what things looked like back then.

    Switching back and forth between themes does not give the colour corruption as it did on my personal iPad... so it must be something that is interfering on there.

    $Wife is using it at the moment, so I cannot wipe/factory reset it.

    At least I got an extra iPad for testing purposes :smile:

    As for the muttley sniggering, copyright law may interfere with that.... I'm not 100% sure on that point. If in doubt, it can be left out, won't be a deal breaker.

    My suggestion is to get a working release out, and worry about green screen additions and other stuff later. Otherwise it'll be too much and will lead to delays etc.

  • Hi, Thanks for this testing! good news.

    I put out a new build late yesterday that might fix the other iPad - or, at least, help a lot.

    The difference between the version that had corrupted colours and the version that failed on start, was that i moved out a lookup table used by the XBR pixel scaling. It turned out that the lookup table was being calculated each time a picture was generated, rather than as a one off.

    So this a bit of a performance hit, but shouldn't really change things, but yet it killed the build altogether.

    So, moving this thing was a clue.

    It turned out that, i hadn't really paid attention to what this XBR lookup table does and how big it is.

    XBR lookup table was 64MB!!

    And is used as a giant RGB -> YUV color-space conversion table.

    Real waste of memory. I got rid of it and replaced it by a fast RGB->YUV conversion. Seems to work and generate the same images :-)

    So, the sudden use of 64MB was stressing some devices. This code is still in the Android build, so I'm planning to compile a new version today and try it on my phone for a bit.

    Even if this does not fix the original iPad problem, it's well worth having as an improvement.

    Thanks again,

  • What sad times are these when passing ruffians can say NI, at will, to old ladies and slack coders can have 64MB lookup tables in games for pocket devices.

    The second part of that sentence, cut from the end of that scene during editing. :-)

  • edited August 2017

    hehehehehe :D

    Now it makes sense that my personal iPad said "nein" when I tried to run it...

Sign In or Register to comment.