Pawn/Guild on Manjaro

edited January 16 in Bugs

Hello,

I haven't had any luck running the appImages for The Pawn and Guild of Thieves on my Manjaro Linux. Both fail with:

This application failed to start because it could not find or load the Qt platform plugin "xcb" in "".
Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.
Reinstalling the application may fix this problem.
Aborted (core dumped)

The new Jinxter appImage runs ok (the title music stutters, but that's not my main concern now).

It seems like whatever library incompatibility existed in the earlier appImages fixed itself in the meantime. Could you re-build the Pawn and Guild appImages?

Comments

  • Hi,
    yes, this is a problem that arises from a conflict between certain versions of Qt and Freetype. The Jinxter appimage indeed has a fix for this. This did also affect some older versions of Fedora and the Ubuntu 17.x series, but they fixed this in the later releases, the Manjaro people unfortunately not (although I cannot tell on which side the problem is created) I thought I had verified that Pawn and Guild were not affected, but...

    We will certaily push updated versions of Pawn and Guild at some time, but unfortunately those require a full new release cycle with all tests and so on. Especially on Linux there is simply so much that is changing all over the time (Qt, sys libs,...). So full rebuilds are not imminent on our todo list.

    I will see if I can rebuild the Pawn and Guild appimages and apply the fix from the Jinxter appimage without rebuilding the games. Perhaps this does the trick. Will get back to you!

    Best,
    Stefan

  • thank you :)

  • Unfortunately the quick try doesn't work. The Qt version in Guild is older than the Jinxter version and it is linked against other system libs. So this is probably only solveable with a real rebuild. Sorry. :(

  • The music stuttering should be fixed with Jinxter 1.2.10.9!

Sign In or Register to comment.