New release of The Pawn

2»

Comments

  • Well, i have to get the animation going for the Guild....

  • edited February 2018

    Necromancy...

    I still have the old installer (v1.0.1.2) of The Pawn. Copied it to kids' laptop (son likes to play the Pawn), installed it, and fired it up. (Had a wee quibble when trying to install The Guild at the same time, but there's a bug... Anyway...)

    I have absolutely no idea what is causing this. My first suspect was QuickTime (from Myst), it was uninstalled and laptop rebooted... no luck.

    Any pointers, tests etc that I can run?

    This is on a Windows 7 32-bit install. Hardware is a Gigabyte W565M laptop, 2Gb RAM

    It does not look good :(

    And a slight detour - GoT (v1.1.0.7) (no, not game of thrones) does the same :

    Regards

    Ook

  • Thanks for the report.

    Try updating your graphics card drivers.

    hm. an orange blob in the corner. Seen that before. Happens whenever opengl or directx is not using sufficient float precision in the shader. However, it looks like the whole UI is borked by the same problem. maybe.

  • Thanks. PM me an install key, will download latest version and test again. Including in a virtualized environment.

  • Message sent.

  • edited February 2018

    @hugh - thanks, got it, installed it in a virtual win7 environment (pre-SP1).

    Surprisingly it works, no issues, except one issue.

    Launching the game (pawn/thief) you get the splash screen. Clicking on the splash screen to start the game brings up a dialog box saying "The program can't start because MSVCR120.dll is missing from your computer. Try reinstalling the program to fix the problem." Keep in mind this is a clean Windows install, nothing else has been installed yet, not even SP1. :)


    Other than that it works. You can play the games, move around and all that. Will hand over to ookson for more testing.

    Will move this VM over to the home laptop tonight and see if the condition persists.

    Regards

  • Thanks for this report.

    The file MSVCR120.dll is part of the Microsoft C Runtime.

    After some digging, I've found out that MSVCR120 is referenced from the bundled SSL libs. The latter are bundled because many Windows system versions are just too old. I tried building our own version of libssl, but unfortunately the DLLs now use different names (and you can't just rename them!)

    So,

    Since each different version of MSVCR is marked with a number, it would be safe to bundle MSVCR120.DLL with the deployment.

    You might like to try copying it into where you've installed The Guild, either from another machine or download it.

  • Interesting re that dll library. But weird that the game(s) still works without it.

    Anyway.

    Now that I have installed both newer versions, I still get the same fuzzy screens.

    And to top it all off, Virtualbox has a case of the sulks. It just won't work. Meh. More funz.

  • Will try to install XP mode. Unfortunately bandwidth at Ookville is restricted, so will have to download at the work, then transfer over via USB stick.

    Hopefully the bandwidth issues can be adressed soon.

  • The game actually will work without the DLL because it's only needed for the SSL libs, which are dynamically loaded. And they are only loaded to perform a secure "latest version" check with Itch.io. Your missing DLL will only cause the update check to fail.

    I've had a lot of problems with graphics and virtualbox, you need 3D acceleration to work. It kinda works eventually, but you have to meddle around with graphics extras. The "guest" stuff.

  • edited February 2018

    @hugh - thanks for the feedback. Will keep that in mind.

    Now it makes sense why I got that message when starting the game up.

    Glad to be of assistance, even if it's a bit late :)

  • Managed to get virtualbox working, had to install an older version.

    Anyway.

    On a clean win7 SP1 install, everything works (except for that missing SSL DLL). No graphic glitches. Ookson will be overjoyed, he can test the games. :)

    Will try to update graphics drivers on the laptop itself, but it'll be touch and go, given the age of this laptop.
  • Thanks for the update. I've added the missing MSVCR120.DLL into the deployment for future releases. I think the numbering scheme used on these DLLs means that DLLs with the same number are the same.

    So i think this is safe.

Sign In or Register to comment.